Lynx R1 update thread

Any idea how to find out the batch?

I have posted the missing apps and the Wifi issue on the Lynx Support page, hopefully they will respond to that.

I’m afraid only Lynx knows the mapping from serial number to batch

I tried installing .apk files using the Demo Manager, but to no avail. When I select the file and click on “Install an apk”, a loading text is briefly displayed and then this:

This happens regardless of the Lynx being connected to wifi. I tried installing while browsing a website on the Lynx at the same time; the error remains. So for now, even .apk files are unavailable…

The Demo Manager also allows for starting something called Scene Home and Virtual Display. However, the Lynx just shows a blank grey screen when doing this (starting the Onboarding app works fine).

I have reported all issues on the Lynx help portal, but no replies there yet. I’m getting more demoralised by the day :unamused:

Well, that’s bad to hear. Luckily you should be able to install a .apk using the Android native tooling, specifically the adb install file.apk command when having the headset connected through USB and given permission to access data.

Thanks for the tip, Paul! Unfortunately, another dead end:

When trying to install an .apk it fails, when trying again the device is supposedly offline.

The headset doesn’t prompt me to give the pc access to it; any idea how to enforce that?

What do you get when you run adb devices? Does it list the Lynx, and as accessible?

Yes, it’s listed but it doesn’t say anything about it being accessible or not.

I tried installing an .apk through SideQuest, but it failed: “A task failed. Check the tasks screen for more info. NFVR.apk: Premature end of stream, needed 4 more bytes.” (task screen doesn’t provide more info than that). I can browse the device in SideQuest, and under Connection Status “Device Authorized” is green (but the rest is red: Quest not detected, Dev Mode not enabled, no ADB detected).

Here the difference I see when I first plug in a Quest Pro (first) versus after accepting file access though USB within the headset (second):

melis@blackbox 15:53:~$ adb devices
List of devices attached
23XXXXXXXXXXXX	no permissions; see [http://developer.android.com/tools/device.html]

melis@blackbox 15:54:~$ adb devices
List of devices attached
23XXXXXXXXXXXX	device

That second part is the same for our device, so it should be okay.

I have managed to install F-droid by downloading its apk from f-droid.org, as mentioned in this video https://www.youtube.com/watch?v=355sp0s8D6k, through the Wolvic browser and use of scrcpy. Then, following that video, downloaded the Lynx Community App Repository. However, all apps of that repository are listed as not compatible with my headset, which is weird but could be because that video (and repo?) is 6 months old (or because we got an early batch?). There is a setting for allowing install of incompatible apps, so I installed a few of them. Not really a success though; buggy and crashing the headset… Morgen weer een dag.

@markg I’m interested in reading more about your experiences with the Lynx R1, hope you’ll keep posting updates. Sounds like it’s not very user friendly yet. Hopefully this will improve, because this device seems to have potential as a privacy-friendly and affordable MR headset, developed in the EU.

1 like

Indeed, very good to see these first results with the Lynx R-1. Let me know if there is anything we can do to help, @markg. Our own R-1 has been on pre-order for a very long time, with no delivery date in sight. I’m hesitant to order another one as you did (i.e. to get it quicker), partly because of the issues you’re reporting.

By the way, the Lynx discord might provide more exposure to any issues/questions you have. There’s a few people on there that are active, and in some cases even someone from Lynx itself :wink:

Thanks for the (mental) support, Wouter and Paul! I’ll keep the updates coming.

We pre-ordered the headsets end of December 2023. When did you, @paulmelis?

Lynx Discord seems promising; I’ll look into it!

1 like

We pre-ordered, with Lynx themselves, in December 2021…

Edit: got the month wrong, due to US date notation :slight_smile:

1 like

Wow, I can imagine having to wait for 2,5 years is asking a lot of people…

Btw, yesterday a colleague of our IT department came by to setup iotroam. We can now add devices to that separate network ourselves, and configure it so that they can login with just a password. Works like a charm (and I don’t have to use my phone as hotspot anymore :sweat_smile:).

Good to hear! That’s exactly what it was meant for :smiley: I’ll let the iotroam colleagues know they’re doing good work

Just noticed this on https://portal.lynx-r.com/support/thread/demomanager-for-mac:

The DemoManager is not supported anymore, and we will transition to a cross-platform web implementation at https://toolbox.lynx-r.com/

So that might explain why it doesn’t do anything for you…

Some interesting Twitter activity after Brad Lynch (aka SadlyItsBradley) made a case for Lynx, specifically in an AR context of being able to access and process camera images, which almost no XR headset currently allows.

Here’s Stan Larroque mentioning camera access was in Lynx from “day1”, which gets some responses from less-than-happy backers still not seeing their Lynx on “day 807”.

In the the same conversation there’s multiple founders asking how they can (e.g. financially) support Lynx, e.g. CIX and Taron Khachatryan. Seems fundraising is still the main bottleneck. And any follow-up from the “March 30” big partnership news is nowhere to be seen.

1 like